升级nginx 1.15后出现nginx: [warn] the “ssl” directive is deprecated, use the “listen … ssl”

作者: 阿伟 分类: linux 发布时间: 2018-06-30 21:06 ė 浏览数 6 没有评论

为了支持TLS1.3,今天把Nginx升级到了1.15 。

使用nginx -t检查配置的时候,发现一个警告:nginx: [warn] the “ssl” directive is deprecated, use the “listen … ssl”

查询了nginx1.15的更新日志。发现是此次更新。去掉了 ssl on的选项。

官方的说法是:配置中在listen 后面已经加了ssl ,那么ssl on的选项是重复的。在配置里将ssl on 注释掉。再次执行nginx -t 警告消失。

可以在这里看到本次的nginx代码修改点:http://hg.nginx.org/nginx/rev/46c0c7ef4913

知识共享许可协议
本作品采用知识共享署名-非商业性使用-禁止演绎 4.0 国际许可协议进行许可。

本文出自阿伟的博客,转载时请注明出处及相应链接。

本文永久链接: https://blog.awei.me/nginx-1-15-nginx-warn-the-ssl-directive-is-deprecated-use-the-listen-ssl/

发表评论

电子邮件地址不会被公开。 必填项已用*标注

Ɣ回顶部